limit IP Address otomatis queue tree dengan script mikrotik

.

Di sini saya coba membuat limit IP Address otomatis queue tree dengan script mikrotik. Otomatis dalam arti kita membuat firewall mangle dan queue tree semua IP Address yang terdapat dalam jaringan kita.
Contoh kasus : Anda ingin membuat queue tree dari semua IP Address, dari 192.168.1.2 – 192.168.1.254. Anda bisa bayangkan seberapa jenuhnya membuat mangle dan queue tree satu-satu.
Bersama tutorial ini kita manfaatkan fungsi script di Mikrotik.

Script – Mangle

Pertama kita mark packet untuk UPLOAD dari semua IP Address yang ada :
:for x from=1 to=254 do={ /ip firewall mangle add chain=prerouting src-address="192.168.1.$x" action=mark-packet new-packet-mark="U_PC_$x" passthrough=no }
Sedikit penjelasan script diatas :
Kita buat variable “x” dri 1-254, dalam src-address kita input class IP yang kita punya di ikuti variable yang kita buat. Trus kita mark-packet dengan nama “U_PC_$x” $x akan otomatis terisi variable yang kita buat yaitu dari 1-254
Kedua kita mark packet untuk DOWNLOAD dari semua IP Address yang ada :
:for x from=1 to=254 do={ /ip firewall mangle add chain=postrouting src-address="192.168.1.$x" action=mark-packet new-packet-mark="D_PC_$x" passthrough=no }
Perubahannya hanya pada chain dan nama paket, konsepnya sama kyk diatas

Script – Queue Tree

Sekarang kita buat top parent pada queue tree untuk digunakan mangle diatas :
/queue tree add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 max-limit=256k name=Upload packet-mark="" parent=WAN priority=8 queue=default;
/queue tree add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 max-limit=1024k name=Download packet-mark="" parent=LAN priority=8 queue=default;
Untuk “max-limit” sesuaikan dengan total bandwidth yang anda terima dari ISP, harus sama atau kurang dari total bandwidth. Jangan lebih karena queue tidak akan berjalan baik. Untuk “parent” sesuaikan dengan nama interfaces di mikrotik anda.
Lanjut kita buat script otomatis yang akan membuat queue masing-masing IP pada top parent di atas
:for x from=1 to=254 do={/queue tree add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=32k max-limit=256k name="U_PC_$x" packet-mark="U_PC_$x" parent=Upload priority=8 queue=default }
:for x from=1 to=254 do={/queue tree add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=128k max-limit=1024k name="D_PC_$x" packet-mark="D_PC_$x" parent=Download priority=8 queue=default }
Untuk limit-at dan max-limit setiap IP Address anda bisa sesuaikan sesuai kebutuhan

Akhirnya mangle atau queue akan terbuat otomatis dari IP 192.168.1.1 – 192.168.1.254 dengan menjalankan script diatas, ga perlu satu-satu soalnya capee donk !
Jangan di Copy Paste mentah-mentah script diatas ke mikrotik anda. Silahkan di mengerti dulu konsep kerjanya
Salam Sukses!
ARTIKEL YANG BERHUBUNGAN :


1 comments:

Kampungjasa said...

makaish gan infonya ya sanagat bagus .. dan kebetulan lagi nyari juga ..
jangan lupa kunjungi situs saya ya http://www.kampungjasa.com

:X ;)) ;;) :D ;) :p :(( :) :( :X =(( :-o :-/ :-* :| 8-} :)] ~x( :-t b-( :-L x( =))

Post a Comment

 
Judul Blog Anda is proudly powered by Pusat Cara | Modif by Junay Sugiyanto™